After careful monitoring overnight, we are pleased to report all systems are operating normally following yesterdays outage of US East 1.
Posted Oct 21, 2025 - 13:27 UTC
Update
All HYPR Authenticate/Control Center tenants have continued to operate normally throughout the day. We will continue to monitor them and their upstream services vigilantly. Please continue to monitor this page for any further updates.
Posted Oct 20, 2025 - 22:01 UTC
Update
As of 5:50 AM EDT, All affected HYPR Customer tenants are restored to normal service. Though all tenants are currently healthy, HYPR is continuing to actively monitor this incident vigilantly.
If you have any additional questions please reach out to HYPR Support via https://csp.hypr.com
Posted Oct 20, 2025 - 14:33 UTC
Monitoring
This morning at approximately 3:00 AM EDT HYPR Became aware of an issue with our upstream provider: AWS. (More info here: https://health.aws.amazon.com/health/status ). As a result several HYPR tenants in the impacted region experienced issues with authentication. Consequently, we also were unable to access this status page until moments ago.
While AWS continues to work on fully resolving the issue, we have instrumented a workaround, and are closely monitoring tenant health.
Posted Oct 20, 2025 - 09:54 UTC
This incident affected: HYPR Systems (HYPR Authenticate).