Workforce Access Client Unavaliable

Incident Report for HYPR Services

Update

Fix identified. Working on rollout plans.
Posted Feb 23, 2026 - 20:25 UTC

Identified

Workforce Access Clients are currently unavailable for download via Control Center.  Please reach out to HYPR Support for alternative download methods. https://support.hypr.com/
Posted Feb 23, 2026 - 20:24 UTC
This incident affects: HYPR Systems (HYPR Authenticate).